Friday, September 26, 2008

Using Logmein with Ubuntu 64 bits.

If you are a user of Ubuntu 64 and you need to acess logmein you will ahve a few problems because theres not java plugin for firefox working ok.

The open source plugins availables are incompatible with sun java or lack of functionalities.

On the other hand, Flash plugin work out of box in ubuntu hardy 64 bits.

After do a little research i found a simple method to get logmein working.

We will install a special version of swiftweasel, running 32 bits code inside a 64 bits OS.

1)Double check universe and multiverse repos are enabled, if dont just goto System -> Adminstration -> Software sources and enable them.

Pantallazo-Orígenes del software

2) Donwload that script, unzip and runit. More detailed instructions from the author here.

3) Choice your distro.

Pantallazo-germangentile@leslie-lx: ~-Documentos-Downloads-64 bits-ff32-3in1

4) Choice internet navigator.

Seleccionar navegador

5) Installing progress.

Instalando navegador Auto

6) Want install Flash? Is not a needed step, ubuntu install it rigth.


7) Install Java? Is required for use logmein.

Instalar Java

8) Install Mplayer Plugin? Recomended.

Instalar MPLAYER

9) The install scripts ask for your username

Pide tu usuario para poder instalar

10) Done. We have a 32 bits firefox running on our 64 bits system.

11) Install the logmein plugin for firefox.

Get it on the logmein web, labs section, aqui . Dont install the deb file, just save that.

Open a terminal , go to the place you save the deb file and type::

sudo dpkg -i --force-architecture logmein-client_1.0.387-1_i386.deb

Done, now you can enjoy using logmein in your 64 bits system.


Wednesday, September 10, 2008

Lazarus testing repositories updated

There's new version in my repositories.

FPC version 2.3.1 revision 11736
Lazarus 0.9.25 svn revision 16526

The instructions on how to configure repositories here.

The code include support for TFrame.

To activate tframe support do the following:

Go to configure build lzaraus, avanced options, field options add:


build and enjoy.

I hope it help you.


PHP Toolkit available - Delphi or lazarus forms to PHP in a single step

It is gratifying to announce that is has released a set of automatic translation of Delphi applications to PHP, more specifically using VCL4PHP.

As the author of the same suggests, allows for three things:

1) Will automatically convert forms delphi or Lazarus to VCL4PHP, while retaining the same provision.
2) Convert Lazarus in a IDE for PHP.
3) Create extensions for PHP using language as pascal.

If you want to see a simple example of its potential diriganse to this site.

The homepage of the project is here